niedziela, 1 listopada 2015

ICDN 1 - Podstawowa konfiguracja switch'a 2960 cz.7





Rozpocznijmy konfigurację urządzenia z poziomu konsoli.

1. Zmiana nazwy urządzenia:

Przechodzimy kolejno w tryb uprzywilejowany oraz globalnej konfiguracji. Na koniec podajemy hostname nazwa_urządzenia

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S2960
S2960(config)#










2.VLAN:

Do tworzenia VLAN-ów wykorzystuje się konfigurowalne lub zarządzalne przełączniki, umożliwiające podział jednego fizycznego urządzenia na większą liczbę urządzeń logicznych, poprzez separację ruchu pomiędzy określonymi grupami portów. Komunikacja między VLAN-ami jest możliwa, gdy w VLAN-ach tych partycypuje port należący do routera lub z wykorzystaniem przełączników warstwy trzeciej.

W przełącznikach konfigurowalnych zwykle spotyka się tylko najprostszą formę VLAN-ów, wykorzystującą separację grup portów.

W przełącznikach zarządzalnych zgodnych z IEEE 802.1Q możliwe jest znakowanie ramek (tagowanie) poprzez doklejenie do nich informacji o VLAN-ie, do którego należą. Dzięki temu możliwe jest transmitowanie ramek należących do wielu różnych VLAN-ów poprzez jedno fizyczne połączenie (trunking). W przypadku urządzeń zgodnych z ISL ramki są kapsułkowane w całości.


Niektóre nowe karty sieciowe komputerów klasy PC (w tym również interfejsy sieciowe laptopów) umożliwiają skonfigurowanie trybu pracy na tryb zgodny z IEEE 802.1Q. Możliwe jest wtedy bezpośrednie podłączenie komputera do portu przełącznika, na którym jest skonfigurowana sieć VLAN. Na takiej karcie można również ustawić korzystanie z wielu VLAN-ów jednocześnie (tzw. trunku).

Na początku skonfigurujemy port, który posłuży do zdalnego łączenia się z przełącznikiem.
Musimy przejść do trybu konfiguracji globalnej. Następnie przechodzimy do trybu konfiguracji interfejsu. Konfigurujemy interfejs vlan1 z adresem 192.168.100.10 oraz maską 255.255.255.0

S2960>enable
S2960#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S2960(config)#interface vlan1
S2960(config-if)#ip address 192.168.100.10 255.255.255.0

S2960(config-if)#

Po konfiguracji vlan1 wyświetlmy czy nasze zmiany zostały wprowadzone. Polecenie show interface vlan1 wydajemy w trybie uprzywilejowanyM.
Widzimy że IP jest przypisane, natomiast niepokojąco wygląda wiersz zaznaczony na czerwono.
Tym zajmiemy się później.

S2960#show interface vlan1
Vlan1 is administratively down, line protocol is down
  Hardware is CPU Interface, address is 00d0.babe.de43 (bia 00d0.babe.de43)
  Internet address is 192.168.100.10/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 21:40:21, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1682 packets input, 530955 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     563859 packets output, 0 bytes, 0 underruns
     0 output errors, 23 interface resets
     0 output buffer failures, 0 output buffers swapped out
S2960#


Powyżej zaznaczony na czerwony wiersz oznacza że  nasz interfejs nie jest włączony. Poniższe polecenie teraz pozwoli nam go włączyć.

S2960> enable
S2960# configure terminal
S2960(config)# interface vlan1
S2960(config-if)#no shutdown

Wracamy do trybu uprzywilejowanego S2960#.
Po ponownym wydaniu polecenia show interface vlan1 powyższy czerwony wiersz  zmieni się na:
 Vlan1 is administratively up, line protocol is up.

W naszym przypadku gdy działamy w środowisku wirtualnym i nie mamy wpiętego przewodu protocol będzie ustawiony na down.

Musimy ustawić jeszcze domyślną bramę, aby możliwe było podłączenie naszego switcha do innej sieci przy pomocy routera. W naszym przykładzie będzie to 192.168.100.1.

S2960> enable
S2960# configure terminal
S2960(config)#ip default-gateway 192.168.100.1










3. Zapis konfiguracji :

Wszelkie zmiany, które wprowadzamy nie są zapisane w pamięci trwałej urządzenia (NVRAM).
Do czasu zapisu przechowywane są w pamięci RAM, wiemy że przy nagłym braku prądu wszelkie zmiany zostaną utracone.

Przechodzimy do trybu uprzywilejowanego:

 S2960> enable
 S2960# show running-config

Polecenie show running-config pokaże nam obecną konfigurację, którą do tej pory zrobiliśmy.

interface Vlan1
ip address 192.168.100.10 255.255.255.0
!
ip default-gateway 192.168.100.1
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!

end

Następnie w tym samym trybie sprawdzamy czy mamy zapisane jakieś inne konfiguracje.

 S2960# show startup-config
 startup-config is not present

Widzimy że żadnej konfiguracji nie zapisaliśmy wcześniej.

Wykonajmy zapis naszej konfiguracji jako startowej. Po wykonaniu polecenia wciskamy Enter, aby zapisać konfigurację.

  S2960# copy running-config  startup-config
 Destination filename [startup-config]?
Building configuration...
[OK]

Zapis się powiódł.
Wykonujemy w trybie uprzywilejowany polecenie reload, aby zrestartować urządzenie.
Ponownie przechodzimy w tryb uprzywilejowany wykonujemy polecenie:

S2960# show running-config

Poniżej widzimy że nasze zmiany zostały zapisane.

interface Vlan1
ip address 192.168.100.10 255.255.255.0
!
ip default-gateway 192.168.100.1
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!

end







4. Przydatne polecenia:

Konfigurując nowe urządzenie wykonujemy wiele poleceń, z których część znajduje się w trybie uprzywilejowanym inne w trybie konfiguracji globalnej.
Przedstawione powyżej show running-config, które jesteśmy w stanie wykonać z trybu uprzywilejowanego. Jednak możemy wykonać je z trybu globalnej konfiguracji.

S2960(config)#show running-config
                ^
% Invalid input detected at '^' marker.

S2960(config)#do show running-config
Building configuration...

Current configuration : 1043 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!

Widzimy że pierwsza próba kończy się błędem, natomiast druga z przedrostkiem do zadziała.




Brak komentarzy:

Prześlij komentarz