sobota, 18 marca 2017

CCNA - Routing pomiędzy sieciami VLAN cz. 20

Kolejną bardzo często wykorzystywaną w sieciach lokalnych funkcją jest routing pomiędzy sieciami VLAN.
O samych sieciach VLAN napisałem poprzednim razem. Routing pozwala na przekazywanie pakietów pomiędzy różnymi sieciami VLAN, dokładnie tak samo gdyby każda sieci VLAN nie była wirtualną ale podpięta do oddzielnego fizycznego portu.
Routing VLAN można skonfigurować na 2 sposoby:


1. Metoda klasyczna - konfiguruje się z wykorzystaniem fizycznych portów do których podpinamy skrętkę lub światłowód i konfigurujemy VLAN


2. Metoda router na patyku(router on a stick) - tutaj konfigurujemy sieci VLAN z wykorzystaniem jednego fizycznego portu, cały ruch przechodzi przez wirtualną listę pod interfejsów.


Ze względu na ograniczoną liczbę portów oraz cenę zakupu routera z większą liczbą fizycznych portów niż 2(1xWAN,1xLAN) lub też dokupieniem karty rozszerzeń(ale tutaj niestety tylko 10mbit/s) zajmiemy się konfiguracją opcji nr. 2 czyli routera na patyku.




1. Konfiguracja routera na patyku:


Potrzebujemy:
1. Router - 2 sieci VLAN 0/0.10 i 0/0.20
2. Switch
3. Host (PC0) - 192.168.10.10/24 - VLAN 10
4.Host (PC1) -192.168.20.10/24 - VLAN 20





Zaczniemy od konfiguracji sieci VLAN na interfejsie routera G0/0.


Konfigurujemy VLAN 10 oraz 20, jak widzimy musimy utworzyć pod interfejsy o numerach odpowiadających naszym siecią VLAN.


Router(config)#interface g0/0.10
Router(config-subif)#encapsulation dot1Q 10

Router(config-subif)#ip address 192.168.10.1 255.255.255.0


Router(config)#interface g0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0

Wydajemy polecenie no shutdown, ale tylko na porcie fizycznym(u nas jest to port g0/0), a nie na porcie VLAN, dzięki czemu uruchomimy fizyczny port a przy okazji również sieci VLAN.

Router(config)#interface g0/0
Router(config)#no shutdown
 
Powinniśmy zobaczyć nasze sieci VLAN:



Na początek ustawimy VLAN 10 oraz 20 na switchu, porty do których podłączone są hosty musimy ustawić w trybie access oraz przypisać do odpowiednich sieci VLAN.
Następnie port g0/1 na switchu, do którego podłączony jest router musimy ustawić w trybie trunk, aby pakiety mogły krążyć pomiędzy naszymi hostami, które mają różne adresu IP(czyli istnieją w różnych sieciach).


Mamy ustawione sieci VLAN:

Switch0(config)#vlan 10
Switch0(config-vlan)#vlan 20



Teraz przypisujemy porty F0/1(VLAN 10) oraz F0/2(VLAN 20)


Switch#configure t
Enter configuration commands, one per line. End with CNTL/Z.
Switch0(config)#interface f0/1
Switch0(config-if)#switchport mode access
Switch0(config-if)#switchport access vlan 10
Switch0(config-if)#exit
Switch0(config)#interface f0/2
Switch0(config-if)#switchport mode access
Switch0(config-if)#switchport access vlan 20
Switch0(config-if)#

Na koniec ustawimy port g0/1 na switchu  jako trunk, aby switch mógł się dogadać z routerem.

Switch0(config)#interface g0/1
Switch0(config-if)#switchport mode trunk
Switch0(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up




Po wykonaniu powyższych kroków mamy działający VLAN - tzn. ping z hosta PC0 do PC1 działa i z PC1 do PC0 również.



















Jednak powyższy zestaw poleceń to minimalny przykład działania VLAN, problem jest taki że jeżeli ktoś ma w firmie 50 komputerów, które można podłączyć do jednego switcha, rzadko kiedy potrzebuje VLAN, które tworzy się aby:
1. Odseparować ruch pomiędzy różnymi działami
2. Zwiększyć możliwości adresowania urządzeń w sieci, jeżeli np. mam w firmie sieć 192.168.100.0/24, mamy tylko 254 adresy, jeżeli stworzymy VLAN, możemy mieć 4096 sieci po 254 adresy każda.   

Dlatego dodamy 2 switch, utworzymy dodatkowe sieci VLAN 30 oraz 40, aby sprawdzić czy taka rozbudowa będzie działać.









Dodajemy VLAN 30(PC2) oraz 40(PC3) na router:

Router(config)#interface g0/0.30
Router(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.30, changed state to up

Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip address 192.168.30.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface g0/0.40
Router(config-subif)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0.40, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.40, changed state to up

Router(config-subif)#encapsulation dot1Q 40
Router(config-subif)#ip address 192.168.40.1 255.255.255.0

Następnie wykonujemy trunk pomiędzy Switch0 oraz Switch1, na porcie G0/2

Switch0(config)#interface g0/2
Switch0(config-if)#switchport mode trunk

Switch1(config)#interface g0/2
Switch1(config-if)#switchport mode trunk

Tworzymy nowe sieci VLAN(30,40) na Switch1.

Switch1(config)#vlan 30
Switch1(config-vlan)#vlan 40






Następnie przypisujemy port F0/1 oraz F0/2 odpowiednio do VLAN 30 oraz 40


 Switch#configure t
Enter configuration commands, one per line. End with CNTL/Z.

Switch1(config)#interface f0/1

Switch1(config-if)#switchport mode access

Switch1(config-if)#switchport access vlan 30

Switch1(config-if)#exit

Switch1(config)#interface f0/2

Switch1(config-if)#switchport mode access

Switch1(config-if)#switchport access vlan 40

Switch1(config-if)#




Po dodaniu drugiego switcha oraz sieci VLAN 30 oraz 40 wraz z konfiguracją routingu dla tych nowych sieci pozwoli na ping pomiędzy, np 192.168.10.10 a 192.168.40.10.

Każdy następny switch dodajemy w taki sam sposób.
Jeżeli na każdym switchu mają być podłączone hosty należące do każdego z w/w sieci VLAN, należy brakujące sieci dodać na każdym switchu, konfiguracja jest pokazana wyżej, kwestia tylko konfiguracji dodatkowych sieci VLAN, portów w zależności od fizycznego podłączenia. 

1 komentarz:

  1. Cudowne! Gratuluję wykonania :-) To idealnie trafia w mój gust.

    OdpowiedzUsuń